1. Home
  2. FAQ
  3. What are the system requirements for BuildSoft software?

What are the system requirements for BuildSoft software?

[Diamonds, PowerConnect, BIM Expert 2017 or newer]

  • Software
    • Operating system: MS Windows 8/ 8.1 or 10 (32 or 64 bit)
      Note: Windows 7 has reached its End of Life phase on January 14, 2020. Microsoft has stopped releasing updates and patches for Windows 7. It’s possible (older versions of) Diamonds/ PowerConnect still run fine on Windows 7, but we can no longer guarantee it.
    • Codemeter Control Center for managing the licenses
      If you install Diamonds/ PowerConnect/ BIM Expert and CodeMeter Control Center is not present, it will be installed together with Diamonds/ PowerConnect/ BIM Expert.
    • Gateway for managing the databases
      If you install Diamonds/ PowerConnect/ BIM Expert and Gateway is not present, it will be installed together with Diamonds/ PowerConnect/ BIM Expert.
    • .NET Framework (version 2.0 and 4.7.2)
      If you install Diamonds/ PowerConnect/ BIM Expert and .NET Framework is not present, it will be installed together with Diamonds/ PowerConnect/ BIM Expert.
    • For exchanging models between Diamonds/ PowerConnect/ Tekla structures/ IDEA Statica/… using BIM Expert, make sure the versions of the softwares are compatible.
  • Hardware (recommended)
    • 12-16GB RAM (Diamonds). Depending on how many other heavy programs (like CAD, Revit, Tekla Structures, …) you want to use simultaneously.
      16GB (BIM Expert)
    • 64-bit Windows OS
    • SSD (Solid State Drive) for storage
      When the calculations in Diamonds are finished, the results are written in a Temp-folder until the model is saved. The reading and writing of this Temp-folder goes quicker when the harddrive is an SSD-drive.
      For a faster response of Diamonds in general: save files on a local disk. Saving in the cloud or on a network can slow Diamonds down.
    • Intel i7 processor (the higher the clock speed, the faster the calculations in Diamonds)

[ConCrete, 12 Build, PowerFrame, PowerPlate]

  • Operating system: MS Windows Vista/ 7/ 8/ 8.1 or 10 (32 or 64 bit)
  • Processor: Intel Pentium 4 with minimum 128 MB RAM

 

Our software is made for a Windows Operating system. If you want to use our software in combination with other operating systems like (Mac or Linux) you should install a virtual machine (like Parallels) and run Windows the the virtual environment.

Was this article helpful?

Related Articles